Back to overview
Downtime

Help centre, secondary address (support.iqhub.cz) and Staff dashboard are down

Dec 23 at 02:57pm CET
Affected services
Help centre, secondary address (support.iqhub.cz)
Staff dashboard

Resolved
Dec 23 at 03:00pm CET

Help centre, secondary address (support.iqhub.cz) and Staff dashboard recovered.

Created
Dec 23 at 02:57pm CET

Help centre, secondary address (support.iqhub.cz) and Staff dashboard went down.